picnichealth - Disruption to PicnicHealth study enrollment pages – Incident details

All systems operational

Disruption to PicnicHealth study enrollment pages

Resolved
Degraded performance
Started 2 months agoLasted about 6 hours

Affected

Website

Degraded performance from 1:15 PM to 7:26 PM

Updates
  • Resolved
    Resolved

    Pages and flows are back to normal.

  • Monitoring
    Monitoring

    Webflow is currently experiencing a service disruption that is impacting pages across their platform globally. Some of our study-landing pages are currently unavailable. We have implemented a redirect so that patients arriving via referral links are routed directly to the study enrollment flow. Patients can continue to enroll — they will just bypass the landing page and go straight to sign-up. We will direct to the study pages once they are back online